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The Drumlin PDF Reader/Publisher Software 
 
Please read and/or print this document first 

Quick start 
Simply use the Drumlin reader/publisher as you would your standard PDF 
reader. Use the Tools menu, Language option, to select your preferred 
language (e.g. French, German etc.). Explore the toolbar and menu items to 
see the various facilities provided – a full list of these functions is provided 
later in this document. Open any .PDF or secured .PDF (this will have the 
additional extension, .DRM) to view and print documents. The Drumlin 
reader supports document viewing, printing, searching, and navigation aids 
including Bookmarks and hyperlinks (if supported in the source PDF) and 
thumbnail views of pages (Thumbs), as illustrated below: 

 

 
 

Navigation around the document is aided by support of zoom-in and zoom- 
out facilities, left and right mouse click operations, and wheel mouse and 
keyboard (PgUp/PgDn and arrow keys) support. For PDF generation we 
recommend use of Adobe’s commercial PDF creation tools.  
 
To view fully secured PDFs (with .DRMX extensions) you will need to use the 
File menu, Authorize option. To create secured PDFs use the File menu, 
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Publish option. Some publishing options required a license version of the 
software, as detailed on the Pricing and Ordering page of the web site. 
 
If you cannot see file extensions such as .doc and .drmx when in the 
Windows file explorer program, open any file folder (e.g. My Documents), 
select the Windows file explorer menu item Tools at the top of the window, 
and choose Folder Options... This will show a tabbed form. Select the View 
tab and see if the item “Hide extensions for known file types” is ticked. If it 
is, then un-tick this box and you will be able to view full file extensions in all 
your folders. 

 

 
 

In addition to PDF files, the Drumlin software now also handles a wide range 
of image file formats, including: GIF, TIF, PNG, JPG and BMP files – all may 
be opened file the File menu, Open dialog, and then viewed and printed, as 
required. Multimedia files cannot be embedded and played, but may be 
accessed via links which could be a screen shot with a ‘click here to play’ 
icon and/or text (try our link).  
 
The use of the Windows clipboard and screen capture programs is restricted 
for some documents – please see the Screen Capture section, below, for 
more details. For further information please read the remaining sections of 
this document, and if necessary, please look at the FAQs and Help pages on 
our web site. 

http://www.drumlinsecurity.co.uk/pricing.html
http://www.drumlinsecurity.co.uk/test.avi
http://www.drumlinsecurity.co.uk/faqs.html
http://www.drumlinsecurity.co.uk/help.html
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Using Drumlin 
The Drumlin software is designed to open and display (view) and optionally 
print standard PDF files and special PDF files that have been converted by 
the document publisher/owner to either the secure .DRM or .DRMX formats.  
 
If you register your copy of the Drumlin software you can publish secure PDF 
documents yourself. Try looking at the properties of this document, 
welcome.drm – use the File menu, Properties option, DRM settings tab and 
you will see the following information (or similar): 

 

 
 

As soon as you have installed the Drumlin PDF software this “Welcome” 
document is displayed (<drumlin directory>\welcome.drm). You can re-open 
this document via the File or Help menus at any time. The Help menu also 
provides a link to the Online Help information. You are now ready to use the 
Drumlin software to read and print secured PDF documents. This process can 
be carried out using the basic (free) Drumlin software or with a range of 
software upgrades that can be purchased, as described on our Pricing and 
ordering web page and below. 
 
The .DRM and .DRMX formats are strongly encrypted versions of PDFs with 
built-in permissioning and digital rights management. Essentially this means 
that when you receive or download a .DRM or .DRMX document it will 
include controls that determine whether you can simply view the document 
(possibly for a certain period or number of occasions), or whether you can 

http://www.drumlinsecurity.co.uk/pricing.html
http://www.drumlinsecurity.co.uk/pricing.html
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also print it, copy it etc. The publisher/owner sets these attributes. Details 
of how to do this are provided later in this document. To view a standard 
.PDF file or a .DRM file simply open the file with the Drumlin program.  

Registration 
In order to view some protected documents, and if you wish to become a 
publisher of such documents, your copy of the Drumlin reader must be 
registered. This requires a connection to the Internet, so please ensure a 
connection is available before you start. Then, go to the Help menu, 
REGISTER option (if you have not already registered your software) to 
register your copy of the Drumlin software. Your registration details will be 
emailed to you, and to enable continued use of the software you must 
respond to the email otherwise your software will expire after a short 
period. The licensing terms can be viewed at any time via the Help menu, 
About option and on the website. To view a fully secured .DRM document on 
another computer a separate copy of the Drumlin reader must be installed 
on that computer (e.g. a laptop), with its own registration details (a 
different username must be specified). If the .DRM file has been generated 
by authorizing a .DRMX file or is ‘User List restricted’ it will not be readable 
on another computer. You will need to copy the .DRMX file to the computer 
in question and obtain a separate authorization key from the 
owner/publisher. 

Authorization of DRMX files 
If you have purchased or been supplied with a Drumlin .DRMX file you must 
first obtain an authorization code from the owner/publisher to authorize this 
so you have a document you can read. This is carried out using the Drumlin 
program’s File menu, Authorize… option to convert this file to a .DRM file, 
which is then readable on your PC (this file cannot be authorized again 
without a new key from the publisher, nor can it be copied to and viewed on 
another computer once authorized). You must be connected to the Internet 
when authorizing files. When the Authorization Code Entry form is displayed 
enter the Code you have been supplied with – you can copy this Code to the 
Copy buffer and then Paste it using your mouse button (right click) or Ctrl+v 
into the field shown. If all is OK the file will be unlocked and saved, and 
then opened for you to view: 

 

 
 
It may also be a requirement (set by the owner/publisher) that you have an 
online connection to the service when you wish to read the document. 
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Please keep a copy of your authorization codes in case of any problems with 
your computer. 

Navigation and document display 
Drumlin includes several facilities to aid fast navigation around PDF files. 
These include the various view and search facilities described above, 
together with support for internal and external hypertext jumps/hyperlinks, 
if the document author has generated such links in the source PDF. If a PDF 
includes a document structure section (e.g. generated from a document 
Contents table) this will automatically be displayed in a re-sizable window 
on the left of the viewing screen, as shown below. In addition, whether or 
not thumbnail images of the document have been generated in the source 
PDF, these are provided via the Thumbs tab of the Navigation window.  
 

 
Tools are also provided to enable you to zoom in or out at any point – these 
are accessible via the toolbar icons, View menu and by right mouse (or “in 
context”) clicking on any page in the document. Other basic functions are 
also provided via the in-context right mouse button click: 
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When copying to clipboard is permitted and the area or line text selection 
toolbar icons are pressed, the in-context menu includes select and copy 
facilities. 

Toolbar and menu facilities 
The standard Drumlin reader toolbar is shown below. The numbers below the 
toolbar refer to the descriptions that follow in the table provided. Many of 
the functions displayed are also provided via menu items (additional 
facilities may be provided via the File, View and other menus, depending on 
the version and setup of the Drumlin software you have installed): 
 

  1    2    3     4    5    6    7     8    9    10  11       11a        12 13  14 15    16 17     18   19   20 21       22       23 24 

Item Description 

1 Open an existing file (File|Open) – a range of file types are supported (.pdf, .drm, etc.) 

2 Print – if enabled. Printing may be limited to a certain number of copies or pages (File|Print) 

3 Email a Drumlin readable file: attaches file to a New Mail item using your email client 

4 Drag: pages may be dragged by holding the left mouse button down or using the mouse wheel

5 Select text by area: if enabled 

6 Select text by line: if enabled 

7 Search: free text search of entire document, single words or strings (View|Text search) 

8 Fit page 

9 Fit page width 

10 Zoom in: fixed zoom in (View|Zoom in) – also provided via right mouse-button click 

11 Zoom out: fixed zoom out (View|Zoom out) – also provided via right mouse-button click 

11a Zoom factor (select from drop down or type in value required) 

12 View single pages 

13 View continuous single pages 

14 View multiple continuous pages 

15 View facing pages 

16 Rotate clockwise 

17 Rotate counterclockwise 

18 View/hide Full Screen mode (press Esc or use the View menu, full screen option to exit mode)

19 View/hide Sidebar showing thumbnails and bookmarks 

20 Go to first page (View|First page) 

21 Go to first page (View|Previous page) 

22 Shows current page/pages: type in box and press Enter key to go to a page (View|Go to page)

23 Go to first page (View|Next page) 

24 Go to last page (View|Last page) 

 
A wide range of image file formats may be opened using Drumlin. Use the 
File menu, Open option, and select Image files as the type to open. Image 
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file types supported include: GIF, TIF, PNG, JPG and BMP files. Operations 
such as view, rotate and printing may all be carried out. 
 
You can select Drumlin as your default PDF reader via the Tools menu (not 
available for Vista users). To unset this subsequently, use the Windows File 
Explorer, select a PDF file and then right click with your mouse and select 
Open With... to pick the program you require. Then use the Choose 
Program... option to pick the program required and tick the “Always open 
with this program” option. This will re-assign PDFs to the selected program. 
You may need to log out as a user and log back in again for this to take 
effect. If you have any problems with this facility please refer to the online 
FAQ page for more information. 

Language selection 
The Drumlin software is now multi-language enabled. English, German and 
French language files plus a number of others are provided with the initial 
installation. Select your preferred language via the Tools menu, Language 
option. Additional languages may be downloaded via the Tools menu, 
Download language files option.  

Clipboard and screen capture operations 
Drumlin automatically restricts the use of the Windows clipboard, print 
screen and screen capture programs for certain documents. The restrictions 
apply to encrypted Drumlin documents (which have a .drm extension) that 
do not have the option “enable clipboard” selected, i.e. by default Drumlin 
documents have the clipboard disabled. When this type of document is 
opened the Drumlin reader disables the Windows clipboard and the Windows 
Print Screen facilities. If, in addition, the Disable Screen Capture option has 
been selected then Drumlin also checks for the existence of screen capture 
programs that may be running (actively, or passively in the background). If 
Drumlin considers that such a program might be running it issues a warning 
message asking you to close the program in question before continuing. To 
close such programs, select the program (if it is open and running) and use 
its Exit option to close it. Some capture programs install an icon on the 
Windows toolbar and may not exit when the program is closed (see example, 
below). If this is the case, then select the icon in question, right click on it, 
and select Exit to close the program fully.  
 

   
 
If Drumlin still detects a running capture program, and you have not been 
able to exit these in the way described, check the documentation for the 
program concerned to see how it should be closed. If all else fails you can 
run the Task Manager (e.g. press Alt+Ctrl+Del to start the task manager in 
most cases) and delete the process identified in the Drumlin message – make 
sure you have selected the correct process first! Users should contact 
Drumlin (info@drumlinsecurity.co.uk) if they wish to request temporary 
enabling of screen capture, having provided a full explanation of why they 
require this facility.  

mailto:info@drumlinsecurity.co.uk
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Publishing facilities 
The Drumlin software may be used to convert your own PDF files to the 
secured .DRM and .DRMX formats, for subsequent distribution and optional 
sale/rental of the copies provided. PDF files can be created using PDF 
Writer/Printer products available from many suppliers – for more details 
please see our web site. To use the Drumlin publishing facility you must first 
register your copy of the Drumlin software. Then select the menu option, 
File and Publish… to view the publishing screen: 
 

 
 

To generate a basic secured document, select a PDF you have already saved 
or created on your PC, using the document selection button shown above (if 
you select a file type other than pdf you may be able to ‘publish’ it by the 
result will not be readable). Enter an optional Description, ISBN and Version 
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number if you wish. Then select the “Generate basic DRM file” selector 
option, check that you have an online connection and press the OK button – 
this will create a .DRM file on your computer in the directory you have 
selected, with the same name but with a .DRM extension. You can now open 
and view this file with your Drumlin reader. Note that you cannot print it, 
and once you have opened and closed it the specified number of times, it 
can no longer be viewed – indeed, even if you try re-creating it or copying it 
from elsewhere you will find that it cannot be opened. To create basic DRM 
files or a fully secured DRMX file without the view and print restrictions 
you will need to purchase a Standard, Pro or Pro+ edition license (as 
described later in this document and on our web page). 
 
To generate a fully secured document with additional controls, as per the 
Permissions settings shown on the screen above, you can select the 
“Generate fully secured DRMX file” option, and then specify the Permission 
options and dates you require: note that -1 in Count fields means unlimited 
(can only be set if an appropriate license has been purchased), 0 means 
“none” and a number like “5” means “limited to 5 times”. If you select the 
“Must be online” option the user must have an online connection to the 
Internet when they try and open the document, but not throughout the time 
they are using it. This option checks the central server to see that the 
document details are valid, including the date range against the server’s 
own clock, and will prevent access if necessary even if the user has altered 
their own computer’s clock. Then make sure you are online and press OK as 
before. This time a document will be created, with the same name and 
directory as before, but with the extension .DRMX added – this is a locked 
.DRM file that can only be read if it is authorized with a special code (see 
Authorization codes, below). 
 
You can use the File menu, Properties option to see the settings made for 
this document. Documents like this can be generated and placed on your 
web site or emailed to end users, and no authorization process is required 
for them to view the document. It can be copied and downloaded any 
number of times without charge or other constraint, but can only be read if 
the user installs a copy of the free Drumlin software. 
 
Drumlin includes three optional extra facilities for secure PDF publishing. 
Each of these is described in more detail later in this document. The first 
two are the User List and Define Watermark facilities illustrated on the 
screen shot provided above, and also shown below. The buttons that access 
these facilities are only enabled if the appropriate software license type has 
been ordered (they are not visible otherwise). Having placed the order to 
upgrade your Drumlin license your user settings on the Drumlin DRM server 
are updated by our team and you will be advised by email of the changes 
that have been enabled. To activate your extra facilities you will need to 
use the Help menu, Updates option which will check our server and update 
your local software settings. The appropriate buttons shown will then be 
accessible. 
 

http://www.drumlinsecurity.co.uk/pricing.html
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The third option illustrated is the Batch Publish button. As with the previous 
two options, this button is only visible for appropriately licensed users 
(Drumlin Pro+ license). It enables selection and secure publishing of PDF files 
simply by specifying a parent directory. The software then generates a 
directory tree of all the PDF files it finds in the parent directory and 
subdirectories, and enables the user to exclude any files they do not wish to 
publish. The privilege settings used for each document (print, view, date 
and other controls) are taken from the settings provided on the underlying 
Publish New Document form. This facility is ideal for customers publishing 
100s or 1000s of documents at a time. 

Password protection 
Most PDF files do not have an OPEN password specified. If this has been 
specified during the PDF creation process (e.g. using Acrobat Professional 
edition) then Drumlin will prompt for this password. However, Drumlin also 
provides the opportunity to specify a password when a .DRM or .DRMX file is 
created. This is case sensitive, so “Secret” is different from “secret”, but 
can be any length or set of characters. This password is embedded in the 
strongly encrypted Drumlin file and the file cannot be opened without 
specifying the correct password. If bulk generation of files is used (see 
below) and a password is specified, it will apply to each file generated. 

Multiple and Bulk generation of secured .DRM and .DRMX files 
When you use the Select PDF file button […] on the “Publish New Document” 
form above, you can choose multiple pdf files by holding down the Ctrl key 
or the SHIFT key, as with other Windows applications. You can then set the 
attributes you require to be applied to all of these files (including a 
password and or user list information), and when you press the OK button it 
will publish each document in your list, in turn, and will provide a list of 
files generated at the end of the process. Each file will have the same name 
as the source document but with the extension, .DRM or .DRMX, as 
appropriate.  
 
The Batch Publish option extends the above facility by enabling selection 
and secure publishing of PDF files simply by specifying a parent directory. 
The software then generates a directory tree of all the PDF files it finds in 
the parent directory and subdirectories (with their file sizes), and enables 
the user to exclude any files they do not wish to publish. The privilege 
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settings used for each document (print, view, date and other controls) are 
taken from the settings provided on the underlying Publish New Document 
form. A Drumlin Pro+ license is required in order to be able to use this 
option. Very large files (e.g. those well in excess of 100Mbytes) are 
identified in the list in a different colour as it is recommended that such 
files should be reduced in size (e.g. using Adobe Acrobat Pro) or split before 
proceeding. Batch processing generates a log file for future reference and if 
an error occurs the log file is displayed so that the problem can be identified 
(e.g. a file that may need splitting). Batch processing continues unless an 
error encountered prevents the process from running. 

File naming 
It is strongly recommended that you use different file names for your various 
source documents and document versions. For example, if you wish to 
provide a sample version of document “Newsletter.pdf” then name this 
source file “Newsletter_Sample.pdf” first, and then create the locally 
generated .DRM version of this file (e.g. “Newsletter_Sample.drm”), setting 
any additional permissions you require. Likewise, if you are expecting to 
issue several versions of a document or newsletter then include a version or 
date-related information in the pdf filename, e.g. “Newsletter_Jan08.pdf” 
or “MyBook_V1.pdf”. When you create a single DRM or DRMX file using the 
publishing facility you will be prompted to provide a filename – with 
multiple files (bulk publishing) the filenames are defaulted and must be 
altered subsequently if you wish to use different names. 
 
Files that are output by Drumlin have the extensions .DRM or .DRMX – you 
can distribute such files in any manner desired, via email, on CD or via web 
access If you cannot see file extensions in your Windows file manager, then 
use this program’s Tools menu, Folder options... setting to change the 
default View settings so the full extensions can be seen. 

Authorization codes 
A free test/trial key will be provided to you on the first few occasions when 
you publish a DRMX document – save this to a disk file. NOTE: this code is 
also automatically copied into your Windows Paste buffer, ready for paste-
ing into the code field when requested (see further, below).  
 

 
 
You can then check that the .DRMX file has been correctly generated by 
using the File menu, Authorize… option to create a .DRM version that you 
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can then view. You are asked which document (.DRMX file) you wish to 
Authorize, and where you would like to save it, and then the Code Entry 
form is displayed. Enter your test key – you can copy it to the Copy buffer 
and then Paste it using your mouse button (right click) or Ctrl+v into the 
field shown. If all is OK the file will be unlocked and saved, and then opened 
for you to view. When you publish subsequent DRMX files you will find that, 
after a few test publications, you do not get a free test key provided. If you 
wish this setting to be altered, allowing test keys for other documents, 
please contact us by email: sales@drumlinsecurity.co.uk. Likewise, it is 
possible for a single authorization code to be used multiple times, if so 
requested – for example, to allow a customer to have two copies of a 
secured document or to have a demonstration document that must be 
authorized but for which you are happy for any number of people to access. 
Again, email us if you require this option. Finally, it is also possible for codes 
to be generated that are specific to a single registered individual (assuming 
they have already installed and registered a copy of the Drumlin software). 
Then you can distribute your .DRMX file in any way you wish (e.g. via a web 
site, CD, via email etc.) without fear of it being copied or decrypted. If an 
end user/customer wishes to view the document they must apply to you for 
an authorization code (or codes if you decide to offer them the option of 
having multiple copies of the document on different computers). Once 
authorized the end user can only view and/or print the document on their 
computer, with the permissions you have specified, and the authorization 
code cannot be re-used by anyone else. 

Publishing locally generated secured files without view/print restrictions 
When you register your copy of the Drumlin Reader a special ‘user record’ is 
stored in our database. By default this permits you to create locally 
generated .DRM files, singly or in bulk, but with the restriction that a 
recipient cannot view the document more than 5 times and they cannot 
print it. However, if you wish to create such documents without these 
restrictions you will need to request this facility. There is a charge for 
enabling unrestricted generation of locally DRM files for a single user 
(upgrade to a Standard, Pro or Pro+ license), as described below. 

Application-specific Watermarking 
This is a facility available to Pro and Pro+ edition licensees. Drumlin supports 
conventional PDF watermarking as a standard feature, but this only provides 
limited security for the publisher. Application-specific watermarking ensures 
that printed documents include a watermark that identifies who printed the 
document and when, providing traceability and accountability. The screen 
shot below illustrates the facilities available. Watermarks are placed on the 
diagonal by default, based on an origin that is the center of the page. Field 
data can be included, as shown, with the following interpretations: 
 
%F filename 
%M machine name 
%C document ID 
%U username 
%I userID 
%D date 

mailto:sales@drumlinsecurity.co.uk
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%T time 
 

 
 
Typically you would create a standard watermark and apply it to any 
documents you wish by ticking the Include Watermark tick box on the 
Publish New Document form. Application-specific watermarking is applied to 
printed documents only, and can be added or removed as required. The 
Preview option provides a visual indication of the positioning, size and font 
on a blank page using the settings of the current default printer.  

Licensing and service notes 
The basic Drumlin Reader/Publisher software is provide free of charge. 
Upgrades to this basic software can be purchased, as described below and in 
the Software matrix diagram. Secured documents (DRM and DRMX files) may 
be distributed without charge.  
 

• Drumlin Standard Edition: Publish unlimited viewings/printings basic 
DRM files. Includes 100 free quota units plus 100 free authorization 
codes 

• Drumlin Pro Edition: as per Standard Edition, plus user-specific basic 
DRM files and application-specific watermarked printing. Includes 100 
free quota units plus 100 free authorization codes  

• Drumlin Pro Plus Edition: as per Pro Edition, plus bulk publishing 
option (select main directory and all pdf files within this 



© Drumlin Security  14 

directory/subdirectory can be published). Includes 250 free quota 
units plus 250 free authorization codes 

    

 

 
 
Basic secured documents (DRM) files do not require authorization in order 
to open and/or print them. Each DRM document published can be supplied to 
any number of individuals without additional cost. If you wish to publish such 
files without limits to the number of times they can be viewed or to specify 
that they can only be viewed by selected pre-registered Drumlin users, a 
software license must be purchased. All license fees include an initial quota 
specifying how many documents can be published. Additional quota units can 
be purchased separately if required. 
 
Fully secured (DRMX) files require an authorization code to enable them for 
reading/printing (they are converted to DRM files and locked to the user's PC 
settings). This is the strongest security we provide and does not require the 
user to have pre-registered with the Drumlin service. Publishers are 
required to order a Drumlin Pro or Pro Plus (Pro+) Edition license to use this 
facility and to take advantage of the extra functionality and free codes 
provided with these versions of the software. Additional DRMX Authorization 
codes can be purchased in blocks of 10, 100, 1000 or more, as required. 
 
Licensing and service notes: Please go to: www.drumlinsecurity.co.uk  for 
details of the latest software licensing and service availability details. A 
software license agreement is issued as part of each installation, whether 
end user or publisher. DRM service provision for publishing and authorization 
is typically very high (>98%) but is not guaranteed to be always available 
24/7/365. 

Obtaining additional authorization codes 
Authorization codes are provided on request by Drumlin security, for the 
documents and in the quantities requested. Use the Pricing and Ordering link 
on the website to place your order and make payment. Then email 
sales@drumlinsecurity.co.uk specifying the document or documents for 
which you require authorization codes (in the case of DRMX files). For basic 
DRM files you do not have to specify the filenames, only that you wish to 

http://www.drumlinsecurity.co.uk/LicenseOrders.html
http://www.drumlinsecurity.co.uk/
http://www.drumlinsecurity.co.uk/pricing.html
mailto:sales@drumlinsecurity.co.uk
http://www.drumlinsecurity.co.uk/LicenseOrders.html
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have the ability to generate unrestricted basic DRMs and the number of such 
files you wish to create (your quota). 
 
For DRMX files your authorization codes will then be sent to you as a text list 
by email. For example: 
 

Code: ovJOaalUVxDiQHPXcQaG 
 
On request these codes can be sent to you as an email attachment in the 
form of a secure .DRMX file or password-protected .DRM file. 

User Lists 
This is a facility available to Pro and Pro+ edition licensees. It extends the 
functionality of basic DRM files so that instead of being readable by anyone 
with the free Drumlin Reader software, they can only be read by a list of 
pre-registered Drumlin users. Once the function is enabled, a simple file 
called userlist.txt must be created and placed in your Drumlin program 
directory (i.e. where drumlin.exe is stored). Each entry should be of the 
form: 
 
<userID>tab character<optional helpful text> 
 

 
 
Once a file of this type is created, start Drumlin, press the User List button, 
and a list like that shown above is then displayed. You can then select from 
this list in the normal manner (single or multiple entries, holding down the 
Ctrl or Shift keys for multiple selections, as required).  
 
Having selected the users you wish to be able to read the document you plan 
to publish, you choose your other document settings and publish the file. 
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The DRM that is created can be sent to anyone, but will only be readable 
that those users with a Drumlin userID that matches an IDs in the list. The 
users must, of course, be pre-registered with Drumlin, and the userIDs 
provided in advance to the person publishing the document. The userID is 
the numerical last part of the Registration information, provided in the 
registration email and viewable via the Help menu, About form. Publishers 
wishing to use this facility are advised to include themselves in the list in 
order to be able to check the file is OK, and to be careful to include all the 
userIDs they require – if users are to be added or deleted, a new file should 
be created (at least, at present this is the case!). We suggest use of file 
expiry in combination with the facility, for extra security. 

Keeping track of your publishing 
To help you keep track of the files you have published and their permission 
settings, a log file called PublishingHistory.csv is created and updated in 
your application data directory: 
 
C:\Documents and Settings\<username>\Application Data\DrumlinSecurity\Drumlin 
 
You can open this file with Excel or a text file editor (e.g. Notepad) and see 
each event with the various settings field names included in the first row: 
 
Publ.Date,DocID,File,Description,Name,Version,ISBN,Type,StartDate,ExpiryDate,Print#,View
#,Pages#,KeepVer,MustBeOnline,MustBeRegistered,AllowNetworkPrinting 

Security notes 
The details of the Drumlin software security framework, including both the 
software security and the service related security facilities, are not, of 
course, published. Publishers may ask us questions regarding to the security 
facilities available which we will endeavour to answer, and there are many 
publishing features and controls that are incorporated into the system but 
which are not apparent or visible. Ultimately it is the responsibility of the 
publisher to satisfy themselves, via thorough testing, that the solution 
provided meets their requirements. 
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Other facilities and services 
The Drumlin menu provides a number of other facilities, notably the Help 
menu, which includes options to view details of your registration status, and 
the automatic Update… facility (not available for Vista users). The latter 
checks the central Drumlin server to see if a new version of the program is 
available, and if so automatically updates your computer with this version. 
Please wait while the update takes place. The update process is fully 
automatic and will close, update and then re-open your copy of the Drumlin 
software. 

Turnkey PDF publishing service 
We can providing a turnkey service, where you supply us with your PDF or 
PDF.DRMX files together with the price you want to sell them at, 
descriptions and cover images (or a ready created web page promoting your 
publications). We then add the details of how to order the publications 
(download version) and the e-commerce facility to accept payment. When a 
customer orders your publication we supply the authorization code directly 
to them, so there is no need for you to obtain and distribute the codes. 
Automated code delivery is possible if required. Payment of your royalties 
are made quarterly in arrears unless otherwise agreed. A simple contract 
provides the terms and conditions for this arrangement. Please note: you 
will be responsible for the promotion of your publication; and you must 
confirm that you are the owner of the copyright to the publications you wish 
us to handle on your behalf. 

Tailored and professional services 
The Drumlin central DRM facility and the Drumlin Reader/Publisher software 
incorporate many additional facilities. These include: central storage of 
encrypted documents; secure (doubly encrypted) distribution of centrally 
stored documents; user-specific drmx document authorization; usage 
tracking and analysis – tailored reports provided at regular intervals; an 
administrative client, for managing files and users; the ability to operate a 
private (user-group specific) service based on designate private servers; 
reporting (from the Drumlin SQLServer database); Drumlin client software 
tailoring (e.g. functionality and/or white labelling). Further details of these, 
and aspects of the security model, are available on request. 

Reader restrictions 
The Drumlin PDF Reader/Publisher provides display and print support for 
most of the features of all current versions of PDF formats. Watermarks 
(foreground and background) and forms may be viewed, but form field 
processing is not supported, nor are embedded or attached files or 
Javascript. Keyword search support is provided. Copying of section of text 
may or may not be permitted, depending on the settings applied.  
 
Currently single file secure publishing is limited to c.150Mbytes per file. 
Publishers with larger files are advised to use the standard Adobe Acrobat 
‘reduce file size’ options if they have larger files than this, or to split these 
very large files into smaller sections using either Adobe Acrobat or one of 
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the widely available PDF Splitter programs (e.g. http://www.a-
pdf.com/split/). 

Technical support 
Please go to: www.drumlinsecurity.co.uk  - there you will find pages 
providing Help and Frequently Asked Questions (FAQs). You can also email 
our technical support via the Contact menu option on the website.  

http://www.a-pdf.com/split/
http://www.a-pdf.com/split/
http://www.drumlinsecurity.co.uk/
http://www.drumlinsecurity.co.uk/help.html
http://www.drumlinsecurity.co.uk/faqs.html
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